Service degradation on Microsoft 365 (Business or Enterprise) and Microsoft Azure

Incident Report for Fluxx Inc.

Resolved

All products operational
Posted Oct 30, 2025 - 08:28 PDT

Update

We are impacted by the Microsoft incident and continue to monitor Microsoft status page: https://status.cloud.microsoft/m365/
During this time, Fluxx users may experience issues with Microsoft Add-ins, Document Sync
Azure services back to operational
Posted Oct 29, 2025 - 19:11 PDT

Update

We are impacted by the Microsoft incident and continue to monitor Microsoft status page: https://status.cloud.microsoft/m365/
During this time, Fluxx users may experience issues with Microsoft Add-ins, Document Sync, Azure
Posted Oct 29, 2025 - 13:49 PDT

Monitoring

We are impacted by the Microsoft incident and continue to monitor Microsoft status page: https://status.cloud.microsoft/m365/
During this time, Fluxx users may experience issues with Microsoft Add-ins, Document Sync, Azure
Posted Oct 29, 2025 - 12:08 PDT
This incident affected: United States Region (Grantmaker).