AWS latency in EU-WEST-1 Region

Incident Report for Fluxx Inc.

Resolved

AWS has advised that full recovery is expected and services returned to normal.
Posted Jan 28, 2026 - 12:15 PST

Monitoring

AWS has indicated early signs of recovery, though the incident is still active.
Posted Jan 28, 2026 - 10:57 PST

Identified

AWS latency in EU-WEST-1 Region may affect some Fluxx customers.
Posted Jan 28, 2026 - 10:06 PST
This incident affected: Europe Region (Grantmaker).