Report & Card Exports Stuck in “New” Status

Incident Report for Fluxx Inc.

Resolved

The backlog of report jobs has fully cleared, and all scheduled and ad hoc reports are now processing normally.
Posted Jan 23, 2026 - 16:34 PST

Monitoring

New report jobs are now processing normally. We are currently working through a backlog of earlier queued jobs, which may take time to fully clear.
Posted Jan 23, 2026 - 12:22 PST

Identified

We have identified the root cause of the issue and are working on implementing a fix.
Posted Jan 23, 2026 - 11:29 PST

Investigating

We are investigating an issue where report and card exports (including Excel exports) are not downloading and remain stuck in a “New” state within the Jobs Queue.
Posted Jan 23, 2026 - 11:12 PST
This incident affected: United States Region (Grantmaker).