Degraded Performance

Incident Report for Fluxx Inc.

Resolved

This incident has been resolved. We experienced a service degradation affecting some clients, resulting in slow responses and temporary downtime. The root cause was traced to a suboptimal database query using an incorrect index, which increased load on the RDS instance.

We resolved the issue by upgrading the affected RDS instance to a larger size, which restored performance. Additionally, a fix addressing the inefficient query has been implemented and will be included in an upcoming release
Posted Apr 11, 2025 - 09:46 PDT

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 08:23 PDT
This incident affected: United States Region (Grantmaker).